BLOCKING WEB AKSES PADA JAM KERJA

Pada suatu perkantoran, terkadang ada pegawai yang mencoba mencuri waktu dengan membuka facebook atau web lainnya pada saat jam kerja. Yang bekerja 8 jam sehari dikantor, biasanya memiliki jam istirahat ditengah jam kerjanya, walau tidak banyak tapi cukup jika hanya untuk membuka facebook atau sebagainya di web. Sebaiknya gunakan waktu se-efisien mungkin.

Pada MikroTik router hal ini bisa diatasi dengan cara memblock situs tersebut via content pada saat jam kerja, dan di perbolehkan pada saat jam istirahat. Yang dalam hal ini jam kerja dimulai pada pukul 08.00 – 12.00, jam istirahat yang dicontohkan ada pada jam 12.00 – 14.00 dan dilanjutkan kembali dengan jam kerja sampai dengan jam 16.00. Waktu sisanya, diperbolehkan kembali (akses web yang diblock). Sedangkan situs yang hendak diblock, sebagai contoh adalah facebook.com dan twitter.com.

Cara ini, sedikit sama dengan “Blocking Web Akses Dengan Filter Content MikroTik“, hanya saja disini kita menggunakan time untuk block nya.

  1. Pertama yang dilakukan adalah menyesuaikan setting jam mikrotik dengan jam kantor.

Untuk melihat jam pada mikrotik:
/system clock print
Jika tidak sama, lakukan set time:

/system clock set time 00:00:00
Teks yang berwarna merah masukkan time yang diinginkan.

2. Buat jalur akses web yang hendak diblock dan memberinya “tanda” (mark connection)

/ip firewall mangle
add chain=prerouting content=facebook.com \
action=mark-connection new-connection-mark=block-web
add chain=prerouting content=twitter.com \
action=mark-connection new-connection-mark=block-web

3 Kemudian buat rule filter yang masuk dan keluar (input dan forward) untuk memblock akses yang telah ditandai (mark connection) dengan nama “block-web” tersebut diatas. Dengan cara mengarahkan (jump target) akses masuk (input) dan akses keluar (forward) yang mengandung content tersebut.

/ip firewall filter
add chain=input connection-mark=block-web \
action=jump jump-target=drop comment=”facebook dan twitter”
add chain=forward connection-mark=block-web \
action=jump jump-target=drop
add chain=drop action=log
add chain=drop action=drop

Dan sebatas ini web yang dimaksud telah diblock, sekarang kita akan set waktu (scheduler) kapan rule ini memblock dan kapan waktunya accept.

4.Sebelum membuat scheduler, kita akan membuat script yang nantinya akan dijalankan oleh scheduler untuk mensetting otomatis rule block-web diatas.
Script untuk accept:

/system script add name=”accept” \
policy=write,read,policy,test, \
source={/ip firewall filter set \
[/ip firewall filter find \
connection-mark=block-web \
action=jump] action=accept}
Script untuk block:

/system script add name=”block” \
policy=write,read,policy,test, \
source={/ip firewall filter set \
[/ip firewall filter find \
connection-mark=block-web \
action=accept] action=jump jump-target=drop}

  1. Sekarang kita membuat scheduler nya, kapan waktunya script tersebut bekerja.

    Scheduler jam 08.00 – 12.00 (waktu kerja):

/system scheduler add name=”jam-08:00″ \
start-date=jan/01/2010 \
start-time=08:00:00 \
interval=1d on-event=”block”
Scheduler jam 12.00 – 14.00 (waktu istirahat):

/system scheduler add name=”jam-12:00″ \
start-date=jan/01/2010 \
start-time=12:00:00 \
interval=1d on-event=”accept”
Scheduler jam 14.00 – 16.00 (waktu kerja):

/system scheduler add name=”jam-14:00″ \
start-date=jan/01/2010 \
start-time=14:00:00 \
interval=1d on-event=”block”
Scheduler jam 16.00 – 08.00 (waktu bebas):

/system scheduler add name=”jam-16:00″ \
start-date=jan/01/2010 \
start-time=16:00:00 \
interval=1d on-event=”accept”
Penjelasan:
– interval=1d artinya script akan looping kembali dalam 1 hari.
– start-date dimulai pada tanggal tersebut (biarkan saja).
– start-time script akan dijalankan pada jam tersebut.
– on-event fungsi pemanggilan script.