Switch alat untuk mengarahkan dari titik satu ketitik lain; alat hubung; sakelar; perangkai; saklar atau alih.

Switch adalah perangkat jaringan yang bekerja dilapisan Data-link, mirip dengan bridge berfungsi menghubungkan banyak segmen LAN ke dalam satu jaringan yang lebih besar.

Switch merupakan pengembangan dari bridge untuk menghubungan segmen jaringan  dengan topologi yang berbeda-beda atau sama. Hanya saja, di saat sekarang kita tahu bahwa network switch digunakan untuk  menghubungkan komputer satu dengan yang lainnya.

Tentu saja switch bisa digunakan juga untuk menghubungkan switch satu dengan switch lainnya, untuk memperbanyak jumlah port, atau memperluas jangkauan dari jaringan (misalkan ada satu gedung dengan gedung yang lainnya). Bahkan apabila kita melihat ke berbagai vendor network equipment, berbagai switch dipecah ke level berbeda seperti core, aggregation dan access. Pemisahan berbagai level ini dikarenakan setiap level dimaksudkan untuk fungsi yang berbeda. Tapi di artikel ini kita tidak bahas khusus tentang hal tersebut.

Lalu ada lagi istilah layer-3 switch dan multi-layer switch. Bagi pemula, kita akan bingung dengan terminologi-terminologi tersebut. Pada dasarnya, istilah layer-3 switch adalah switch yang memiliki router di dalamnya (router terletak di layer-3 pada OSI Layer). Sedangkan multi-layer switch intinya adalah layer-3 switch, hanya saja memiliki fitur-fitur tambahan untuk memproses informasi pada OSI layer-4 dan seterusnya. Lebih lanjut tentang hal ini akan dibahas di bagian VLAN dan OSI Layer.

Switch yang beredar di pasaran terdiri dari dua jenis, yaitu unmanaged (tidak dapat di-manage) dan managed.

Unmanaged Switch ; keuntungan dan kerugiannya

Unmanaged switch adalah switch yang tidak dapat di-manage… maksudnya adalah switch tersebut pada saat kita membelinya, hanya bisa kita nyalakan dan tancap semua kabel UTP ke switch tersebut, dan sudah berfungsi dengan baik. Unmanaged switch biasanya dipilih oleh pengguna-pengguna yang memang tidak ingin ‘dipusingkan’ oleh konfigurasi peralatan jaringan, karena sekedar plug-and-play. Selain mudah dipasang, tentu saja karena tidak adanya modul management di dalam switch, harga dari switch tersebut akan lebih rendah dibandingkan switch yang managed.

Namun, apabila terjadi masalah dengan jaringan kita, kita tidak akan bisa melakukan troubleshooting dengan mudah, karena memang switch nya tidak bisa diapa-apakan :D .

Apa sih contoh masalah yang paling sering terjadi ??? Dari beberapa pengalaman pemakai, problem yang paling sering terjadi di antaranya ip address conflict, tidak bisa connect, virus jaringan, dll.

IP address conflict, mestinya sering terjadi, dan apabila jaringan sudah mulai tersebar di berbagai area, akan sangat susah melakukan troubleshooting komputer mana yang menyebabkan masalah tersebut. Problem seperti ini jangan dianggap remeh, karena bisa saja seseorang di jaringan kita iseng-iseng mengganti IP nya dengan IP address server, atau router kita. Nah, kalau sudah terjadi seperti itu, bisa-bisa seluruh jaringan kita akan mengalami masalah besar !! :D

Tidak bisa connect…. biasanya terjadi dengan beberapa tipe network card tertentu yang tidak kompatibel dengan switch. Ini kemungkinan disebabkan karena adanya kegagalan proses autonegotiation antara si switch dengan network card. Jika kita menggunakan managed switch, kita masih bisa melakukan setting terhadap speed nya atau half duplex/full duplexnya. Tetapi dengan unmanaged, tentunya hal ini tidak bisa dilakukan.

Virus jaringan …. Apa ada di antara kita yang belum pernah ‘kebagian’ virus jaringan ini ??? Mestinya semua sudah pernah mengalaminya. Virus jaringan… lebih tepatnya kita sebut dengan virus/spy-ware yang memanfaatkan jaringan untuk melakukan proses pengembang-biakannya, akan sangat merepotkan jaringan kita, dan sering kali membuat seluruh switch menjadi mati total !! Tentu saja penulis tidak bermaksud menyatakan bahwa dengan managed switch hal ini akan teratasi. Namun dengan adanya managed switch, kita bisa memanfaatkan fitur-fitur yang ada di dalam switch tersebut seperti membatasi besarnya paket yang keluar dari suatu komputer, atau menyalakan fitur Quality of Service yang bisa memprioritaskan paket-paket tertentu di jaringan.

Cara Konfigurasi Switch CISCO :

Agar dapat mengkonfigurasikan switch, terlebih dahulu kita harus menghubungkannya dengan PC atau LapTop sebagai terminal konfigurasi. Untuk itu kita membutuhkan kabel penghubung dengan jenis Rollover dan adapter RJ-45 to DB-9.

cisco5

Cara konfigurasi CISCO Switch :

Konfigurasi dasar

Switch>enable

Switch#configure terminal

Switch(config)#hostname office

office(config)#banner “cisco switch”

office(config)#enable password cisco

office(config)#line console 0

office(config-line)#password console

office(config-line)#login

office(config-line)#exit

office(config)#line vty 0 4

office(config-line)#password telnet

office(config-line)#login

office(config-line)#exit

office(config)#exit

Sekalian ditambahkan bagaimana cara konfigurasi Trunk

Switch>enable

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#interface fastEthernet 0/1

Switch(config-if)#switchport mode trunk

Switch(config-if)#switchport trunk encapsulation dot1q

Switch(config-if)#switchport trunk allowed vlan all

Switch(config-if)#no shutdown

Switch(config-if)#exit

Switch(config)#interface fastEthernet 1/1

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 10

Switch(config-if)#no shutdown

Switch(config-if)#exit

Switch(config)#interface fastEthernet 2/1

Switch(config-if)#switchport access vlan 20

Switch(config-if)#switchport mode access

Switch(config-if)#no shutdown

Switch(config-if)#exit

Switch(config)#interface fastEthernet 3/1

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 30

Switch(config-if)#no shutdown

Switch(config-if)#exitSwitch#show vlan

VLAN Name                             Status    Ports
—- ——————————– ——— ——————————-
1    default                          active    Fa0/1, Fa4/1, Fa5/1
10   marketing                        active    Fa1/1
20   support                          active    Fa2/1
30   operation                        active    Fa3/1
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
—- —– ———- —– —— —— ——– —- ——– —— ——
1    enet  100001     1500  –      –      –        –    –        0      0
10   enet  100010     1500  –      –      –        –    –        0      0
20   enet  100020     1500  –      –      –        –    –        0      0
30   enet  100030     1500  –      –      –        –    –        0      0
1002 enet  101002     1500  –      –      –        –    –        0      0
1003 enet  101003     1500  –      –      –        –    –        0      0
1004 enet  101004     1500  –      –      –        –    –        0      0
1005 enet  101005     1500  –      –      –        –    –        0      0