Pertama, User EXEC Mode. Ketika user berada pada daerah mode ini, user hanya bisa mengakses Catalyst secara terbatas. Tidak bisa melakukan konfigurasi apapun, kecuali hanya melihat isi konfigurasi yang telah berjalan (juga hanya terbatas). Tanda bahwa user berada pada User EXEC Mode adalah jika perintah pada layar terminal linux atau Hyper Terminal atau Command Prompt atau program lainnya yang digunakan, seperti di bawah ini :
router>
Kedua, Privileged EXEC Mode. Pada mode ini, user bisa mengakses Catalyst bahkan sampai konfigurasi apapun di dalamnya. Untuk bisa ke Privileged EXEC Mode ini, user cukup mengetikkan perintah “enable” pada User EXEC Mode. Terlihat pada contoh dibawah :

router>enable
router#

Tampilan “router#” menunjukkan bahwa user berada pada Privileged EXEC Mode. Setelah masuk ke mode Privileged, konfigurasi bisa dimulai. Gambaran umum konfigurasi catalyst sebagai berikut.

Setting Password

router>enable
router#configure terminal
router(config)#enable password password
router(config)#enable secret secret

Setting Host Name

router>enable
router#configure terminal
router(config)#hostname nama-host

Setting Vlan

router>enable
router#configure terminal
router(config)#vlan nomor-vlan
router(config-vlan)#name nama-vlan

Setting IP Address pada Vlan

router>enable
router#configure terminal
router(config)#interface vlan 1
router(config-if)#ip address address mask
router(config-if)#no shutdown

Setting Deskripsi pada Port

router>enable
router#configure terminal
router(config)#interface nama-port
router(config-if)#description “Uplink ke PPSI”
router(config-if)#end

Setting IP Gateway

router>enable
router#configure terminal
router(config)#ip default-gateway address

Setting Port-Speed dan Link-Mode

router#configure terminal
router(config)#interface nama-port
router(config-if)#speed 100
router(config-if)#duplex full

router#configure terminal
router(config)#interface nama-port
router(config-if)#switchport mode access
router(config-if)#switchport access vlan nama-vlan

router#configure terminal
router(config)#interface nama-port
router(config-if)#switchport mode trunk
router(config-if)#switchport trunk allowed vlan nama-vlan

Setting Line VTY

router#configure terminal
router(config)#line vty 0 4
router(config-line)#login
router(config-line)#password password

Setting Line Con 0

router#configure terminal
router(config)#line con 0
router(config-line)#login
router(config-line)#password password

Melihat Semua Konfigurasi

router#show running-config

Menghapus Semua Konfigurasi

router#erase startup-config
router#dir
router#delete flash:vlan.dat
router#dir
router#reload

Sekarang kita mulai penjelasan untuk masing-masing bagian.

1. Setting Password

Setting password dilakukan untuk mencegah akses user yang tidak memiliki hak akses. Setting password ini harus dilakukan pada Privileged EXEC Mode. Caranya seperti yang telah dijelaskan secara singkat diatas, yaitu :

router>enable
Perintah ini digunakan untuk mengubah dari User EXEC Mode ke Privileged EXEC Mode.

router#configure terminal
Setelah berhasil masuk ke Privileged EXEC Mode, maka perintah selanjutnya adalah “configure terminal”. Perintah ini digunakan untuk mengubah konfigurasi pada terminal Catalyst.

router(config)#enable password Contoh@jA
Kita akan masuk pada mode konfigurasi (nama modenya apa saya lupa). Perintah yang dimasukkan adalah “enable password Contoh@jA”. Contoh@jA adalah contoh password yang digunakan.

router(config)#enable secret TestJu9@
Sebenarnya, hal terpenting untuk pengamannya adalah pada perintah “enable secret blabla” ini. Karena, inilah yang akan diminta oleh Catalyst ketika seorang user ingin mengaksesnya. Perintahnya sama seperti “enable password blabla” tadi, hanya saja yang diketikkan adalah “enable secret TestJu9@”. TestJu9@ adalah ‘password’ yang akan diminta ketika kita ingin masuk dari User EXEC Mode ke Privileged EXEC Mode.

Perbedaan antara “password” dan “secret” adalah pada enkripsinya. Untuk “enable password Contoh@jA”, maka kata “Contoh@jA” akan ditampilkan tanpa enkripsi jika kita tidak menset Catalyst untuk mengenkripsi password. Sedangkan untuk “enable secret TestJu9@”, maka kata “TestJu9@” akan dienkripsi meskipun Catalyst tidak diset untuk itu. Contohnya seperti berikut :

enable secret 5 $1$Kev5$QvRbEv1Queo9.y.hCGjAj/
enable password 7 Contoh@jA

2. Setting Hostname

Setting Hostname bertujuan untuk memberi identitas pada Catalyst. Jika kita bermain di jaringan besar seperti LAN, atau bahkan WAN, tentu Catalyst yang digunakan bukan satu atau dua unit, tapi bisa mencapai puluhan bahkan ratusan unit. Hal ini tentu membingungkan jika semua Catalyst memiliki nama yang sama. Untuk itu, diberikanlah nama pada Catalyst agar masing-masing memiliki identitas yang unix.

Sama seperti setting password sebelumnya, untuk bisa men-setting hostname, maka kita harus masuk ke Privileged EXEC Mode. Selanjutnya, ketikkan perintah “hostname nama-host”.

router>enable
router#configure terminal
router(config)#hostname Router-Ged-A
Perintah “hostname Router-Ged-A” diatas berarti menamakan Catalyst dengan nama “Router-Ged-A”.

Router-Ged-A(config)#
Ini adalah tampilan yang akan dihasilkan ketika selesai mengetikkan “hostname Router-Ged-A” dan menekan enter. Terlihat bahwa Catalyst tidak lagi menggunakan nama default-nya, tetapi sudah menggunakan nama lain.

Tips : Untuk pemberian nama, sesuaikan dengan tempat meletakkan Catalyst tersebut. Misal, Catalyst akan diletakkan pada gedung B lantai 8, maka nama yang mudah untuk pemeliharaannya adalah “Cisco-Ged-B-8?.

3. Setting Deskripsi Sebuah Port

Sebelumnya Anda bayangkan dulu. Kalo ada 100 Catalyst pada sebuah jaringan besar, dan tiap Catalyst mempunyai 12 sampai 24 port, maka kalau dijumlah ada sekitar 1200 sampai 2400 port. Hmm… Tentunya sangat sulit menghafal satu-persatu port-port Catalyst tersebut. Agar mudah untuk me-manage, di tiap port diberikan identitas agar tidak tertukar. Lantas, bagaimana cara konfigurasi untuk memberi nama masing-masing port. Berikut perintahnya :

router#configure terminal
router(config)#interface fa0/1
Untuk bisa mengakses sebuah port, perintah yang dipakai adalah “interface nama-port”. Misal “interface fa0/1? berarti mengakses interface Fast Ethernet port ke 1. Setelah memasukkan perintah ini, maka user akan berada pada area Fast Ethernet 1 — hal ini berlaku untuk port lainnya, seperti Gigabit, sesuai akses yang diinginkan.

router(config-if)#description “Uplink ke Provider”
Perintah ini bertujuan memberikan deskripsi ke sebuah port, yakni dengan mengetikkan “description deskripsi-port”. Misalnya, perintah “description Uplink ke Provider”, berarti deskripsi untuk port ini adalah “Uplink ke Provider”. Karakter maksimal untuk deskripsi ini adalah sebanyak 85 karakter (maaf, saya agak lupa maksimal berapa karakter, tapi kalau tidak salah 85).

4. Setting gateway

Untuk bisa menyetting IP Gateway pada Catalyst, konfigurasi yang harus dituliskan adalah sebagai berikut :

router#configure terminal
router(config)#ip default-gateway 192.168.70.1
Ketikkan perintah “ip default-gateway alamat-gatewaynya”. Misalnya, kita ingin memberikan gateway 192.168.70.1, maka perintah yang harus diketikkan adalah “ip default-gateway 192.168.70.1“. Jika konfigurasi ini terlupa tidak dituliskan, maka catalyst tidak akan bisa ‘berjalan’, karena tidak ada ’sumber’ acuan untuk jalur internet.

5. Setting Speed dan Mode

Setting speed dan mode dilakukan pada sebuah port. Berikut perintah yang harus dimasukkan.

router#configure terminal

5.1 Konfigurasi Speed

router(config)#interface nama-port
Perintah “interface nama-port” sebenarnya sudah dibahas diatas, tetapi disini saya mengingatkan kembali bahwa perintah ini adalah untuk masuk ke suatu interface port tertentu yang dikehendaki. Misalnya interface Fast Ethernet, Serial atau Gigabit.

router(config-if)#speed 100
Perintah ini digunakan untuk menyeting secara permanent kecepatan maksimum yang bisa di-handle oleh Catalyst. Penyetingan ini berdasarkan kebutuhan yang ada pada suatu jaringan. Selain itu, juga bisa didasarkan pada perangkat lainnya, dalam hal ini misalnya “Converter”.

Sebelumnya saya jelaskan sedikit, converter yang kita bahas sekarang adalah satu alat yang bisa mengubah sinyal dari sinyal cahaya ke dalam sinyal digital dan sebaliknya, dari sinyal digital ke cahaya (untuk diteruskan ke dan dari fiber optik). Lihat gambar disamping. Converter memiliki nilai kerja yang berbeda-beda. Ada yang hanya mampu sampai 10 Mbps, ada yang sampai 100 Mbps. Hal ini tergantung converter tersebut.

Jika converter memiliki nilai kerja 100 Mbps, maka kita bisa mensetnya menjadi 100 pada konfigurasi speed catalyst. Jika converter 10 Mbps, maka kita bisa mensetnya menjadi 10. Sebenarnya, catalyst bisa secara otomatis mendeteksi speed dari Converter dan menyesuaikan diri. Namun, terkadang hal ini dibutuhkan jika memang kedua titik hubungan dikonfigurasi seperti itu.

router(config-if)#duplex full
Perintah ini untuk membuat sebuah catalyst bekerja menjadi sistem duplex (dua arah).

5.2 Konfigurasi Mode

Setelah menyeting speed pada port, selanjutnya adalah menyetting mode yang akan digunakan. Mode yang akan dipakai ada dua macam, yaitu :

A. Mode Access

Pada mode ini, user dapat melakukan setting vlan untuk jalur broadcast domain hanya satu vlan (tentang vlan insya Alloh saya bahas dalam tulisan tersendiri). Hal ini berguna misalnya untuk pengetesan jaringan lewat Catalyst langsung ke PC, yang membutuhkan sebuah mode Access. Atau juga koneksi ke HUB yang akan berjalan hanya jika mode dalam keadaan access. Perintah yang dimasukkan adalah sebagai berikut :

router(config-if)#switchport mode access
Perintah ini untuk menyetting port tertentu menjadi ber-mode access. Karena bermode access, maka hanya satu vlan yang bisa dideskripsikan pada port ini.

router(config-if)#switchport access vlan nama-vlan
Perintah ini untuk mendeskripsikan satu vlan tertentu yang bisa diakses melalui port yang sedang di konfigurasi ini. Misalnya, kita akan mendeskripsikan vlan 200, maka perintahnya adalah “switchport access vlan 200“.

router(config-if)#no shutdown
Jangan lupa mengetikkan perintah ini. Karena jika tidak, interface yang telah di konfigurasi akan tetap dianggap masih shutdown.

B. Mode Trunk

Pada mode ini, dalam satu port user bisa mendefinisikan lebih dari satu vlan. Hal ini berguna misalnya untuk koneksi antar Catalyst, yang memang melewatkan vlan dari satu LAN ke LAN lainnya. Berikut perintah yang harus dimasukkan.

router(config-if)#switchport mode trunk
Perintah ini untuk menyetting port tertentu menjadi ber-mode trunk. Karena bermode trunk, maka pada port dapat didefinisikan banyak vlan.

router(config-if)#switchport trunk allowed vlan nama-vlan
Perintah ini untuk mendeskripsikan vlan-vlan apa saja yang akan dilewatkan dalam port tersebut. Misalnya, kita akan melewatkan vlan 200 sampai vlan 204 dan vlan 500 sampai vlan 507,maka perintahnya adalah “switchport trunk allowed vlan 200-204,500-507“.

Jadi, ketika kita ingin mengkonfigurasi sebuah Catalyst pada port 10 yang akan melewatkan vlan 200 sampai 340, dengan speed 100 dan duplex full, perintah yang kita ketikkan adalah sebagai berikut :

router#configure terminal
router(config)#interface fa0/10
router(config-if)#switchport mode trunk
router(config-if)#switchport trunk allowed vlan 200-340
router(config-if)#speed 100
router(config-if)#duplex full
router(config-if)#no shutdown

6. Setting Line VTY dan Line 0

Line VTY

Line vty itu adalah jalur yang digunakan untuk mengakses Catalyst dari jarak jauh. Ketika bermain di jaringan besar, tentunya sulit mendatangi satu persatu catalyst untuk dicek keadaannya, penambahan konfigurasi yang dibutuhkan dan lain sebagainya. Untuk itulah, diperlukan jalur yang khusus digunakan untuk melakukan hal ini. Dan itulah line vty.

Penyetingannya adalah sebagai berikut :

router#configure terminal
router(config)#line vty 0 4
Perintah ini untuk masuk ke line vty 0 sampai 4 (artinya jalur/terminal ke 0 sampai ke 4).

router(config-line)#login
Perintah ini dituliskan agar admin jaringan bisa masuk atau login ke dalam catalyst melalui jarak jauh (misalnya telnet). Jika perintah ini tidak atau lupa ditulis, maka admin tidak akan bisa mengakses sama sekali melalui jarak jauh.

router(config-line)#password M@sihContoh
Sebuah password diperlukan untuk melindungi catalyst saat diakses dari jarak jauh. Jika tiga kali salah memasukkan, maka koneksi akan diputus.

Perintahnya ada sedikit perbedaan dengan pemberian password yang lalu, yakni tidak perlu mengetikkan “enable”, tapi cukup “password isi-password”. “M@sihContoh” adalah password yang harus dimasukkan saat user ingin mengakses catalyst dari jarak jauh tersebut.

Line Con 0

Sama seperti line vty, line con 0 juga merupakan jalur yang digunakan untuk mengakses catalyst. Perbedaannya adalah, kalau line vty untuk jarak jauh, maka line con 0 adalah koneksi melalui Console. Jadi, langsung pada catalystnya. Semua konfigurasi catalyst pertama kali dilakukan lewat port Console ini.

router#configure terminal
router(config)#line con 0
Perintah ini digunakan untuk mengakses line con 0.

router(config-line)#login
Perintah ini harus dituliskan agar password menjadi aktif. Jika perintah ini tidak dituliskan, pada saat user mengakses catalyst lewat console, maka akses akan langsung masuk ke Privileged Mode, walaupun password sudah disetting.

router(config-line)#password isi- password
Perintah ini tentunya sudah jelas sekali yaitu untuk mendefinisikan password pada line con 0, sehingga setiap user yang ingin mengakses catalyst melalui console akan dimintai password terlebih dahulu. Hal ini untuk melindungi catalyst dari akses yang tidak berhak. Karena biasanya, catalyst ditempatkan pada daerah yang jauh dari jangkauan admin jaringan. Bisa saja, orang yang berada dekat dengan catalyst tersebut ingin mencoba mengakses lewat console. Password melindungi catalyst dari hal tersebut.

7. Keluar Konfigurasi

router(config-if)#end
Setelah semua konfigurasi selesai, user bisa mengetikkan perintah “exit” atau “end” untuk keluar dari mode konfigurasi terminal, kembali ke Privileged Exec Mode dan akan tampil seperti berikut :

router#

Melihat Konfigurasi
Untuk melihat hasil konfigurasi menggunakan perintah berikut :
router#show running-config
Setelah masuk ke privileged mode, maka user cukup menuliskan “show running-config”. Maka akan tampil semua konfigurasi yang telah dibuat.

Di bawah ini adalah contoh konfigurasi catalyst mulai dari masuk ke User EXEC Mode, Privileged Mode sampai menampilkan semua detail konfigurasi.

User Access Verification

Password: —> (Disini diminta password VTY 0 4 atau Con 0)

Switch-Ged-A>enable

Password: —> (Disini diminta SECRET)

Switch-Ged-A#show running-config

Building configuration…

Current configuration : 1937 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Switch-Ged-A

!

enable secret 5 $1$Kev5$QvRbEv1Queo9.y.hCGjAj/

enable password 7 151E045C25232C2521

!

ip subnet-zero

!

vtp mode transparent

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

vlan 5

name HOTSPOT

!

vlan 142,144-149

!

interface FastEthernet0/1

switchport access vlan 149

switchport mode access

speed 10

duplex full

!

interface FastEthernet0/2

switchport access vlan 148

switchport mode access

!

interface FastEthernet0/3

description “GED-5?

switchport access vlan 142

switchport mode access

!

interface FastEthernet0/4

description “GED-9?

switchport access vlan 142

switchport mode access

!

interface FastEthernet0/5

description “GED-7?

switchport access vlan 142

switchport mode access

!

interface FastEthernet0/6

description “GED-8?

switchport trunk allowed vlan 1,5,142

switchport mode trunk

!

interface FastEthernet0/7

description “UPLINK-GD-2?

switchport trunk allowed vlan 1,5,140-149

switchport mode trunk

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface Vlan1

ip address 192.168.70.42 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.70.1

no ip http server

!

line con 0

line vty 0 4

password 7 151E045C25232C2521

login

line vty 5 15

password 7 151E045C25232C2521

login

!

!

end

Switch-Ged-A#

Menghapus Konfigurasi

Ada kalanya sebuah catalyst perlu dihapus semua konfigurasi di dalamnya. Entah karena ingin diganti yang baru, atau alasan lainnya. Daripada menghapus satu-persatu konfigurasi di tiap port atau tiap vlan, akan lebih mudah menggunakan perintah berikut :

router#erase startup-config
Perintah ini digunakan untuk memulai menghapus konfigurasi.

router#dir
Kemudian, kita lihat dulu adakah file “vlan.dat” di catalyst tersebut. Jika ya, maka kita dapat melanjutkan ke perintah berikutnya.

router#delete flash:vlan.dat
Perintah ini digunakan untuk menghapus file “vlan.dat” yang berisi semua konfigurasi catalyst.

router#dir
Untuk memastikan bahwa file benar-benar hilang, ketikkan perintah ini.

router#reload
Reload catalyst.

9. Menyimpan Konfigurasi

Gunakan perintah “copy running-config startup-config”.

router#copy running-config startup-config
Destination filename [startup-config]?
Building configuration…
[OK]
router#

Selamat Mencoba………..!!!