ospf1Router O

Current configuration : 762 bytes
!
version 12.2
service password-encryption
!
hostname Router
!
!
enable password 7 0822455D0A16
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
ip address 10.10.15.3 255.255.255.0
clock rate 56000
!
interface Serial3/0
no ip address
shutdown
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
router ospf 20
log-adjacency-changes
network 10.10.15.0 0.0.0.255 area 0
network 10.10.12.0 0.0.0.255 area 0
network 10.10.13.0 0.0.0.255 area 0
network 10.10.14.0 0.0.0.255 area 0
!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
end

Router 1

version 12.2
service password-encryption
!
hostname Router
!
!
enable password 7 0822455D0A16
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
bandwidth 64
ip address 10.10.15.5 255.255.255.0
!
interface Serial3/0
bandwidth 64
ip address 10.10.12.6 255.255.255.0
clock rate 56000
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
interface Serial6/0
bandwidth 64
ip address 10.10.13.5 255.255.255.0
clock rate 56000
!
router ospf 10
log-adjacency-changes
!
router ospf 20
log-adjacency-changes
network 10.10.12.0 0.0.0.255 area 0
network 10.10.13.0 0.0.0.255 area 0
network 10.10.15.0 0.0.0.255 area 0
network 10.10.14.0 0.0.0.255 area 0
!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
end

Router 2

Current configuration : 682 bytes
!
version 12.2
service password-encryption
!
hostname Router
!
!
enable password 7 0822455D0A16
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
ip address 10.10.12.4 255.255.255.0
!
interface Serial3/0
ip address 10.10.14.4 255.255.255.0
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
router ospf 20
log-adjacency-changes
network 10.10.12.0 0.0.0.255 area 0
network 10.10.14.0 0.0.0.255 area 0
!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
end

Router 4

Current configuration : 682 bytes
!
version 12.2
service password-encryption
!
hostname Router
!
!
enable password 7 0822455D0A16
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
ip address 10.10.16.4 255.255.255.0
!
interface Serial3/0
ip address 10.10.14.3 255.255.255.0
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
router ospf 20
log-adjacency-changes
network 10.10.14.0 0.0.0.255 area 0
network 10.10.16.0 0.0.0.255 area 0
!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
end

Router 3

Current configuration : 700 bytes
!
version 12.2
service password-encryption
!
hostname Router
!
!
enable password 7 0822455D0A16
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
ip address 10.10.13.3 255.255.255.0
!
interface Serial3/0
ip address 10.10.16.5 255.255.255.0
clock rate 56000
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
router ospf 20
log-adjacency-changes
network 10.10.13.0 0.0.0.255 area 0
network 10.10.16.0 0.0.0.255 area 0
!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
end

Router4# sh ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 4 subnets
O       10.10.12.0 [110/3124] via 10.10.16.5, 00:22:46, Serial2/0
O       10.10.13.0 [110/1562] via 10.10.16.5, 00:22:56, Serial2/0
O       10.10.15.0 [110/3124] via 10.10.16.5, 00:22:46, Serial2/0
C       10.10.16.0 is directly connected, Serial2/0

Ping ke router O

Router4#ping 10.10.15.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.15.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 78/90/94 ms

Berarti hasil konfigurasi berhasil…!!!  Selamat mencontek